| |
| | |

Apple Phoon Forum

 Forgot password?
 Register
View: 1073|Reply: 6

Power mac g5, swapped CPUs, kernel panics, fail to boot from install DVD

[Copy link]

Post time: 2014-01-07 05:41:41 |Show all posts
Using Power Mac
Hello, my Power Mac g5 dual core had been acting up for the past several weeks; it froze at first, would only boot on occasion, only to freeze again, or work for short periods of time. After going through various forums, I decided to clean and reseat everything inside the machine ( logic board, CPUs, optical drive, etc) The next day, when the machine was reassembled, it booted up and worked well, however it was incredibly loud ( fan noises) Upon closer inspection, I realized that I had placed the CPUs in the 'wrong' order ( top and bottom were switched) I tested each of the CPUs alone, and discovered one of them was not working at all (the 'top' one) When I placed the bottom processor at the top, the machine turned on, and booted up! However it was still as loud as ever. I also noticed that when both CPUs were placed in the computer in the 'wrong order' the Computer only detected one CPU. I assume the reason the machine was so loud was because of said misplacement. Nevertheless, when it was configured this way, it was working well, just really loud. When the CPUs were placed in the 'correct' order, the machine did not boot.
Now, I have another Power mac g5 but this one has a single processor ( logic board had gone bad on this machine, my current power mac g5 I had bought from a relative) Feeling a little overly confident, I decided to try a little experiment...
I placed the CPU from the single processor machine into the dualcore. The first message I received was something about an invalid memory in Openfirmware mode. When it asked if I wish to boot or shut down, i decided to boot... It failed to do so. When I tried to replace the CPU that had worked, the computer had a kernel panic: 'unable to find platform for driver' message appeared.
Numerous attempts to boot from the install DVD have not worked either; Once the spinning gears appear below the apple, the screen goes grey and a message reading, 'you need to restart your computer' comes up. I fear my little experiment may be the culprit.
If anyone can help with any suggestions as to how (if possible) reset the computer so that any error that resulted from inserting the single processor into my dualcore machine can be corrected, would be greatly appreciated.
        Power Mac G5, Mac OS X (10.4.11)
Reply

Use magic Report

Post time: 2014-01-07 14:54:40 |Show all posts
Hello,
I'm sorry to say my luck has pretty much ran out since I last posted.
Since I had two G5s with different issues ( one has a bad logic board, the other the CPUS) I tried to switch out
the logic board on my newer g5 with the older one. The experiment did not work ( simply more kernel panics)
but upon trying to piece the machines back together as they were originally, two pieces of plastic from the cable connectors from the power supply to the logic board of the dualcore machine broke off ( the cables themselves can still be attached to the logic board but still, what an eyesore...) Then upon finishing up, I discovered a component that had broken off of the logic board itself ( I'm not sure what they are called).
Then today I was placing the CPU back into my single processor machine when one of the screws broke off into the insert behind the logic board.
I regret my decision to ever open up either machine in the first place. I doubt Apple will want to help me now considering the damage I've done to both computers.
I'm hoping that at this point I could find a refurbished G5 (not online) purchase it and hopefully get a few more years out of it...
Anyway, I just wanted to update you on my situation, and thank you for all the help and advice you provided.
Thanks again.
Reply

Use magic Report

Post time: 2014-01-07 13:23:10 |Show all posts
You've done amazing so far!!!
https://discussions.apple.com/thread/3806109?start=0&tstart=0
https://discussions.apple.com/thread/3344773?start=0&tstart=0
You still really need ASD, 2..8 I tthinkj, but it's not available to the public really.
Reply

Use magic Report

Post time: 2014-01-07 12:05:42 |Show all posts
The current G5 that is giving me trouble is the A1047 model of dual processor machines from 2004.
As far as replacing the thermal paste I wouldn't know how, haha. Aside from regular dissassembly and such, I am not at all computer savvy, especially when it comes to hardware issues. In fact the only reason I decided to open up my current G5 was because I had done the same to my previous machine. Upon putting it back together, it worked as well as it did before I took it apart; random flashes of the power up light, and an occasional chime. In other words, my fiddling around with it didn't worsen its condition, haha. So after initial hesitance, I went to town on my current computer, only to ruin my streak of good luck (it booted up, worked fine with no freezes) when I inserted the processor from the single CPU machine.
Reply

Use magic Report

Post time: 2014-01-07 10:51:12 |Show all posts
Did you replace the Thermal paste 'tween the CPUs & heatsinks?
Which exact G5 is it?
Reply

Use magic Report

Post time: 2014-01-07 09:15:19 |Show all posts
Hello,
I placed the CPUs as you suggested, and typed in the commands in open firmware. The machine starts up, and boots up to the apple logo, but nothing further. But at least no more kernel panic! Thank you for your suggestion. Its remained this way for a few minutes now.
Earlier today, I ran an apple hardware test and it detected something wrong with the logic board. the message read something like '2 fan drive bay' but that was all it found.
Okay, still just the apple logo, but no spinning gears. After several minutes it shut down on its own. But as I've mentioned, no more kernel panic so that's a relief. Where do I go from here?
Thanks again!
Reply

Use magic Report

Post time: 2014-01-07 07:41:28 |Show all posts
Hi, was the single CPU the same speed & revision as the duals?
One thing to try, put the working CPU in the first position, the bad dual one in the second position.
You might try this, thanks to old comm guy...
This can be done in open firmware,(boot with cmd+option+O+F held down).
setenv boot-args cpus=1
reset-all
Do you have ASD for that G5?
Reply

Use magic Report

You have to log in before you can reply Login | Register

Archive| Apple Phoon

2019-12-11 08:14 GMT-8 , Processed in 0.109608 sec., 27 queries .

Powered by Discuz! 7.2

Release 20121101, © 2001-2019

To Top