| |
| | |

Apple Phoon Forum

 Forgot password?
 Register
View: 1028|Reply: 7

PowerBook G4, PowerPC software recommendation

[Copy link]

Post time: 2014-01-01 05:36:36 |Show all posts
I have a PowerBook G4 non-intel, what is the highest OS X I can put? I'm willing to upgrade RAM if needed because it only has 512, but I don't want to upgrade to 10.6 if it wont handle it. Should I upgrade it to an intel processor, is this even possible?
        iMac, OS X Mountain Lion (10.8.2)
Reply

Use magic Report

Post time: 2014-01-01 16:23:07 |Show all posts
You do raise a good point, but
For my two cents: If he donates it, he should donate it "as is" and let the education institution upgrade it as necessary.
That being said, if anecdotal reports I have reviewed here about trouble running education software on Lion/Mt. Lion Macs are any indication of what is in use, I would have to report that most of the problems revolve around OS X software that requires Rosetta and not Classic software.
Also, we are not really sure if his Powerbook G4 already has Leopard on it, which would not support Classic; from reviewing his posts.
Reply

Use magic Report

Post time: 2014-01-01 15:18:07 |Show all posts
I don't work in education but I understand that there is a fair bit of old education software which some teachers still use and which will not run directly in OSX but will run in OSX using Classic.
Upgrading the G4 PB to 10.5 would mean access to these would be lost as 10.5 does not support Classic.
Reply

Use magic Report

Post time: 2014-01-01 13:38:03 |Show all posts
Glad that you took it in the spirit it was intended!
I am sure that there are other uses that a school could make of a Powerbook G4 in the interim!
Reply

Use magic Report

Post time: 2014-01-01 12:01:40 |Show all posts
ok that was really funny!!!
I'm just trying to help out the school i work for to manage their iPads better and I just have this old thing lying around that is basically just a dust collector and I assume will remain as one  .
Thanks for your help and when I hit the lottery i'll be able to help them out.
Reply

Use magic Report

Post time: 2014-01-01 10:22:48 |Show all posts
Apple Configurator v1.2.1 requires Lion or Mt. Lion, neither of which will install into your Powerbook G4. He recommended Leopard, the most advanced version of OS X that will run on a PowerPC Mac such as yours.
Snow Leopard 10.6, was the first version of OS X to require an Intel CPU.
The only way to "upgrade" your Powerbook G4 to an Intel processor is to glue a MacBook Air to it!
Reply

Use magic Report

Post time: 2014-01-01 08:33:51 |Show all posts
and with OS you recommended I cannot use the apple configurator, correct?
Reply

Use magic Report

Post time: 2014-01-01 07:02:25 |Show all posts
1. Mac OS X 10.5.8.
2. No, it's not possible.
(78976)
Reply

Use magic Report

You have to log in before you can reply Login | Register

Archive| Apple Phoon

2020-02-20 10:40 GMT-8 , Processed in 0.098084 sec., 27 queries .

Powered by Discuz! 7.2

Release 20121101, © 2001-2020

To Top